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This help documentation is under construction, just like the program itself.    There is much that is 
still not documented and some of what is here may be incorrect.



License Information

Copyright © 1995 John A. Junod.    All rights reserved.

This program in its current version may be freely distributed and may be freely used.    This may or
may not be true of all future versions.    The ONLY restriction is that this version may NOT be 
SOLD.    You can include it on distribution diskettes and CD-ROMs provided such is not for the 
sole purpose of distributing this program.    Documentation accompanying such distribution must 
contain this notice and the statement: 
WS_Watch is Copyright © 1995 John A. Junod.    All rights reserved.

THE INFORMATION AND CODE PROVIDED IS PROVIDED AS IS WITHOUT WARRANTY OF ANY 
KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT
SHALL JOHN A. JUNOD BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, 
INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES,
EVEN IF JOHN A. JUNOD HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.    IN ANY
CASE LIABILITY WILL BE LIMITED TO THE AMOUNT OF MONEY THAT JOHN A. JUNOD 
RECEIVED FROM YOU FOR THE USE OF THIS PROGRAM.

This program was developed entirely on personal equipment using personal time and personal resources.
My association with the U.S. Army has no bearing on the design or implementation of this program nor 
does it imply that the U.S. Army, Fort Gordon, the United States Military Academy or the U.S. Army 
Computer Science School endorse the use of this program.



Description
The primary purpose of this program is to make active checks on hosts that are listed in its database file 
and to graphically display the status of those hosts.    In addition, this program provides access to finger, 
whois, ping, traceroute and name server lookup (see tools).

Since this program is still being developed, there are some things that are not the best in the world (like 
the map editor) and things that may not work correctly.    If you find something that does not seem to be 
working correctly or want to make a suggestion on features to implement or how to implement a feature, 
send me mail.    I will not guarantee that I will respond to your mail (I would not have time to do any 
development if I responded to all my mail!), but you can be sure I will read it and consider any 
suggestions and attempt to correct any problems.    Please also realize that I am developing this program 
un-funded so development is not constant.    Development of this program is not a part of any of my real 
jobs.

This program can also read .DB files created by my EGA Netwatch program (which requires FTP's 
PC/TCP to work).    EGA Netwatch cannot read files from this system.

Session settings are saved in the WS_WATCH.INI file in your WINDOWS or WINNT directory.    It is be 
safe to delete this file anytime you want to set things back to default.



Requirements
This program requires Microsoft Windows NT, Microsoft Windows 95 or Win32s and a working Windows 
Sockets DLL. (It works best on Windows NT or Windows 95)

This program is designed to work on any Winsock DLL, however it works BEST on the Microsoft TCP/IP 
32 stack that comes with Windows NT 3.5 and Windows 95.    In the Windows 3.x environment it works 
best on a stack that supports raw sockets (such as Ipswitch's Acadia, FTP PC/TCP, Novell LWP, Trumpet 
Winsock, Super-TCP, Netmanage, etc..).    It does NOT work well on Microsoft's TCP/IP stack for 
Windows for Workgroups and uses a completely different method for determining if a host is up or not. 
(This probably wont work with your Microsoft TCP/IP-32 under your Win32s.)

This program has been tested on: (refer to ws_watch.txt for further info)

Windows NT 3.5 - Microsoft TCP/IP
Windows 95 - Microsoft TCP/IP
Windows for Workgroups 3.11 - Ipswitch Acadia 1.0 - Win32s 1.2
Windows for Workgroups 3.11 - SuperTCP - Win32s 1.2
Windows for Workgroups 3.11 - Trumpet 2.0b - Win32s 1.2



Installation
1.    Install a Windows Sockets stack.
2.    Install Win32s (if you are using Windows 3.x)
3.    Make a directory and copy WS_Watch.EXE and WS_Watch.HLP to the directory.
4.    Make a link in your program manager to point to WS_Watch.
5.    Create your own map, MAKE SURE YOU SAVE IT!!



The Main Window
The Main Window of WS_Watch graphically displays the database of items and networks that it is 
monitoring and provides menus (also see tools) to access the other features of WS_Watch.

Items that are responding to the monitor are displayed in green. Items that are not accessible or have not 
responded to 4 consecutive monitor requests are displayed in red. Items that are displayed in yellow have
missed at least one monitor request.    Note that these colors are changable by pressing the Colors button
in the Options dialog.

To display additional status information about a item, you can point to the top left corner of an item and 
depress the left mouse button. (See Host Information)    The small window will remain on the screen as 
long as the left mouse button is depressed.    

To access some of the advanced features of WS_Watch, you can click the right mouse button on the top 
left corner of a item and a pop-up menu will appear.    Provided the environment you are working in 
supports it, you can then ping the item, trace the route to the item or edit the items properties.    You can 
also double click the left mouse button on the top left corner of the item and automatically execute the 
connect program associated with an item.

You can move hosts by holding one of the SHIFT keys down and dragging an Icon to its new location with
the LEFT mouse button.    You can move lines by holding one of the SHIFT keys down and dragging a line
to its new location with the RIGHT mouse button.    (Note you MAY have to press the STOP or ABT button 
to return to normal operation.)



Pop-up Menu
You can click the right mouse button while pointing to an item or on a blank area of the map.    A pop-up 
menu will appear somewhere close to where you clicked.    This menu allows you to create new items, 
delete items or provides you access to the items properties or access a few utilities.

NEW->HOST
To create a new host in normal display mode, point to an open area in the map and click the right 
mouse button and select New->Host from the pop-up menu.    At that point, a dialog will appear 
requesting the items information detail.    (See Host Information) 

NEW->LINE
To create a new line in normal display mode, point to one desired endpoint of the line and click 
the right mouse button.    After selecting New->Line from the popup menu, (with the left mouse 
button!), move the mouse cursor to the second desired endpoint of the new line and click the 
RIGHT mouse button.

DELETE->HOST
To delete a host in normal display mode, point to an existing host on the map and click the right 
mouse button and select Delete->Host from the pop-up menu.    At that point the program will 
remove the item.    (NOTE: Additional information on the item is not removed from the INI file as it 
may be used by other maps.)

DELETE->LINE
Point to one of the endpoints of the line you wish to delete, click the right mouse button and select
Delete->Line from the popup menu.

CONNECT
This executes the connect program defined for the current item or if no special program is 
defined, it will use the defined Telnet program.    If no special characters are on the program line, 
the IP address is appended to the end of the program line before attempting to execute the 
program.    (You can also double click the left mouse button on an item and automatically execute 
the connect program.)

PING
This opens the ping window and pings the ip-address of the current item using the current set of 
options.    You can change the number and size of the pings by pressing the Options button in the 
ping window. 

TRACEROUTE
This opens the traceroute window and traces the route to the ip-address of the current item using 
the current set of options.    You can change the max number of hops and size of the probes by 
pressing the Options button in the traceroute window. 

PROPERTIES
This allows you to change the properties of the item using the same dialog as when the item was 
created.    (See Host Information)



Using edit mode
The purpose of this program is not to draw fancy pictures!    So do not expect too much from the editor.    I 
will, however, continue to improve it.    (secondary priority)    Sorry if its cryptic!

Basically the editor uses the left mouse button to work with hosts and the right mouse button to work with 
lines (or nets).    (You can actually create new hosts and delete old hosts by bringing up the popup menu 
on the normal desktop and selecting New->Host from the popup menu.)

CREATING A NEW HOST
To create a new host in edit mode, select the Add->Host menu item and then drag the NewHost 
symbol to its desired location and click the left mouse button.    At that point, a dialog will appear 
requesting the items information detail.    (See Host Information)    Optionally, you can point to an 
open area in the map and click the right mouse button and select New->Host from the pop-up 
menu while in the normal display mode.

MOVING A HOST
To move a host, point to the top left corner of the host (in edit mode), hold the left mouse button 
down and drag the host to its desired location.    Optionally, you can hold the SHIFT key down and
drag a host with the left mouse button while in the normal display mode.

CHANGING HOST INFORMATION
To change a hosts information, double click on the host (in edit mode).    Optionally, you can point 
to an item and click the right mouse button and select Properties from the pop-up menu while in 
normal display mode.

DELETING HOSTS
To delete a host, select the Delete->Host menu item and point to the top left corner of the item to 
delete and click the left mouse button.    Optionally, you can point to an item and click the right 
mouse button and select Delete->Host from the pop-up menu while in normal display mode.

CREATING A NEW LINE
To add a new line, select the Add->Line menu item and point to one of the end points for the line 
and click the right mouse button.    After releasing the mouse button, a line will follow the mouse 
from that end point as you move the mouse.    Move the mouse to the other end point and click 
the right mouse button.

MOVING A LINE
To move an existing line, point to an end point, press and hold the right mouse button down and 
drag the end of the line to its new end point and release the right mouse button.    When multiple 
lines terminate at the same location, you may have to move lines out of the way to get to the line 
you want to move. Optionally, you can hold the SHIFT key down and drag a line with the right 
mouse button while in the normal display mode.

DELETING A LINE
To delete an existing line, select the Delete->Line menu item and point to the end of the line you 
wish to delete and click the right mouse button.    When multiple lines terminate at the same 
location, you may wish to move other lines out of the way before to insure you delete the desired 
line.



Host Information
DISPLAY NAME:

This is the name that is displayed on the screen and should be from 1 to 8 characters long.

ADDRESS/NAME:
This can be a name that can be resolved or it can be an IP address.    This field is limited to 25 
characters.

INFO LINES 1 & 2
These fields are purely informational and can be used as you see fit.    I would suggest putting in 
the POC for a system or location or description in these fields.    This information is displayable by
clicking on the hosts during normal operation.

CONNECT PRGM:
The command entered here is executed with the IP address of an item as the last argument on 
the command line when you select Connect from the popup menu for a item.    (See connect 
program)

SYSTEM TYPE:
This option is used to select the icon to display when the Use Icons option is enabled.    Select the
desired type from the drop down list.

TYPE:
Currently, only TCP/IP or None are selectable.    This defines for the system how to talk to the 
item.

MONITOR:
When this is selected the item is checked on each poll.    If this is not checked (or if None is 
selected as a Type), the item is displayed as gray.

LOG ACTIVITY:
When this is selected a log entry is written in the mapname.LOG file in the same directory of the 
map when the item has missed 4 polls and when the item recovers after missing 3 or more polls.

SOUND:
Defines the sound file that will be displayed when the host goes down.    Snd1=down1.wav, 
Snd2=down2.wav, Snd3=down3.wav.    When multiple hosts go down simultaneously, the highest 
numbered sound has priority.



Connect Program
The Connect program that is entered in the item information dialog supports some special values.    This 
fields usefulness is tied to the Connect menu item in the pop-up menu.    If the field is left blank the 
program used to connect to an item is the program defined as the Telnet program in the system options 
dialog.

Special values

[LOAD] database_file_name%
This causes the specified database to be loaded.    This is intended to be used in conjuntion with 
an item that has a System Type of Net.

%l
This is replaced with the contents of the label field of the items properties.

%n
This is replaced with the contents of the address/name field of the items properties.

%a
This is replaced with the ip-address of the item.

%1
This is replaced with the contents of the info1 field of the item.

%2
This is replaced with the contents of the info2 field of the item.

Examples:

  Connect prgm:  d:\mosaic\mosaic.exe http://%a/
  Connect prgm:  d:\apps\telnet.exe %1
  Connect prgm:  [LOAD] subnet.db%



System Options
You can change a number of options by selecting the File->Options menu item in the main window or by 
pressing the Options button in various dialogs.

SECONDS BEWEEN CHECKS
This is the number of seconds between polls.    The countdown of this is displayed in the title bar 
of the window if the Show Timer in Title option is enabled.

DISABLE AUTO CHECK 
If this option is enabled, the program will not automatically poll items for their status.    You will 
have to press the CHK button in the lower right corner of the screen to find the current status of 
the items.    All other functions of the program are available in this mode.

SECONDS TO WAIT BEFORE TIME-OUT
This is the number of seconds to wait for a response from a host.    This should be set to the 
smallest possible value.    For a local network, a time-out of 2 seconds is usually valid.    For a 
long distance (or slow path) network, this time-out may need to be as high as 10 seconds.

TELNET
Program to execute when the user selects Tools->Telnet and default tool for Connect popup 
menu option.    (also see tools)

FTP
Program to execute when the user selects Tools->FTP (make sure you take a look at WS_FTP, 
another excellent program I wrote!)    (also see tools)

ENABLE SOUNDS
Controls the sounding of the alarm when a host goes down or comes up.

FIXED FONTS IN MAP
Changes handling of fonts in item display.    Try it both ways!

FIXED FONTS IN TOOLS
Changes handling of fonts in tool displays like whois, finger, lookup, etc..

RAW SOCKET ICMP PING
This should be selected if you are using a stack that supports raw sockets, such as Ipswitchs 
Acadia, FTP Incs OnNet, Trumpet Winsock, etc.

MICROSOFT ICMP PING
This should be selected if you are using Microsofts TCP/IP 32 on Windows NT or Windows 95.    If
this is checked and you are not using the correct platform, you will get an error on ICMP.DLL.

SHOW TIMER IN TITLE
Toggles the timer in the title.

SOLID BACKGROUND
The background can either be the same color as your desktop or one of the solid colors that is 
available in the Colors dialog.    If the option is unchecked, the program will use the color of your 
desktop (this can be changed from the control panel or in the screen properties).    If the option is 
checked, the program will use the nearest solid color to the color that you have set in the Colors 
dialog.    Changes to this option do not take affect until you restart the program.

USE ICONS



The system will display Icons in place of the simple host name if this is checked.    The type of 
icon is determined by the System Type property of the item.

LABEL ICONS
The simple name will be displayed below the icon when Use Icons and this option are enabled.    
Note that the color of the background under an icon is the nearest solid color to the current color 
of the icon.



Changing Colors
You can change some of the colors by pressing the Colors button in the Options dialog.    (NOTE: Not all 
colors will be available for use in all systems or for all fields.    You will need to experiment for the best 
results on your system.)

To change a color, select the color name in the list box and click on the color patch that you wish to 
change to.    The current setting for a name is displayed to the right of the list box, above the color 
patches.

The colors that can be modified are:

Responding
This is the color used to paint the icon or text background of an item that is responding to active 
checks.    Default is solid light green.

Lost 1 pkt
This is the color used to paint the icon or text background of an item that has timed out to 1 active
check.      Default is solid light green.

Lost 2 pkts
This is the color used to paint the icon or text background of an item that has timed out to 2 
consecutive active checks.      Default is solid yellow.

Lost 3 pkts
This is the color used to paint the icon or text background of an item that has timed out to 3 
consecutive active checks.      Default is solid yellow.

Lost 4-7 pkts
This is the color used to paint the icon or text background of an item that has timed out to 4 to 7 
consecutive active checks.      Default is solid light red.

Lost 8+ pkts
This is the color used to paint the icon or text background of an item that has timed out to 8 or 
more consecutive active checks AND for items that have a network error such as network 
unreachable.      Default is solid light red.

Inactive
This is the color used to paint the icon or text background of an item when monitoring is disabled 
for the item.    Default is dark grey.

Background
This is the color used to paint the background of the screen if the Solid Background option is 
enabled in the Options dialog.    Default is light gray.

Text
This is the foreground color used for the text.    Default is black.



Tools
This program also provides access to a small number of tools that are often used during the 
troubleshooting of problems on a network.

These include:

TELNET
Provides access to a telnet application that you may have on your system.    Telnet is not included
in this program.    Go to the Options dialog to define the telnet program.

FTP
Provides access to a ftp application that you may have on your system (might I suggest 
WS_FTP!).    FTP is not included in this program.    Go to the Options dialog to define the ftp 
program.

LOOKUP
Provides access to the name resolving functions in your network stack.    What comes back from 
any lookups is determined by what your systems network stack will return.    Usually, you can 
enter an IP address and get back the official name of the system or you can enter a name and get
back the IP address of the system.

PING
Provides access to ICMP ping.      A set number of ICMP echo requests are sent to the specified 
IP address and the network response is displayed on the screen.    The default is to send 5 
packets of    56 bytes each to the address.    Response time is displayed in milli-seconds and will 
vary due to network load.    Advanced options are available by pressing the Options button in this 
dialog.

TRACEROUTE
Provides a means of seeing the actual network path that an ICMP echo request takes to arrive at 
a destination host.        Times are displayed in milli-seconds.    The second column is the difference
from the previous response time.    Response times will vary due to network load.    Advanced 
options are available by pressing the Options button in this dialog.

WHOIS
Provides a means of looking up network information (or user information) from the various 
network information providers.    For Department of Defense lookups, use NIC.DDN.MIL as the 
WAIS host.    For non-military sites, use RS.INTERNIC.NET as the WAIS host.    Additionally, 
many sites such as MIT provide their own lookup hosts.

FINGER
Provides a means of querying a host by use of the finger protocol.    (Try fingering 
zj8549@trotter.usma.edu).      Usually, you can enter just a host name and see what users are 
currently logged on and then specify a userid@host to display additional information about a 
specific user.    NOTE: Many sites (especially military) have disabled the finger servers for security
reasons.



Hints and Known Problems
DO NOT EXIT THIS PROGRAM WHILE A CHECK IS IN PROGRESS!    If you do, you may have to 
reboot the system to rerun the program or to remove file concurrency errors on the EXE.    There are 
checks to help correct this situation but they are not 100% complete.

Appears to be a bug when running on Win32s on the Microsoft TCP/IP stack.    Works on some systems 
and not on others.    Program seems to time-out on all remaining hosts after the first host fails. This MAY 
be a problem in my timer routines so I am looking at that.

You MAY have to move other lines out of the way before you can reference the line you want.    When 
deleting a line, you need to try to click on an end of the line where no other lines meet it.



About the author
The following is provided so that you have an idea of who I am, why I write programs like this and so you 
may understand my lack of response to much of my electronic mail.    (I do still read it, so keep it coming!) 
My future is that I will stay in the Army until at least May 1998, so this is NOT a thinly veiled 
resume looking for a job.

I am a Master Sergeant in the United States Army, currently stationed at Fort Gordon, Georgia, as the 
NCOIC (Non-Commissioned Officer In-Charge) of the PDNEB (Professional Development Network 
Engineering Branch) at CSS (the U.S. Army Computer Science School).    The PDNEB primary mission is 
to improve network connectivity and network services for the PDN (Professional Development Network) 
organizations.    Secondary missions include improving network connectivity and network services for the 
U.S. Army Signal School and for Fort Gordon.

I have been in the Army since 1978 and have served as a Forward Observer, a Brigade Fire Support 
NCO, Instructor (computer), the NCOIC of the GoldCoats at West Point, the Chief of Academic Network 
Engineering Branch at West Point and the NCOIC of Technology Integration Division at CSS.

My awards in the Army include the Legion of Merit, numerous Army Commendation Medals, Army 
Achievement Medal, Good Conduct Medals, Overseas Service Ribbon, and NCO Professional 
Development Ribbon.    My Army education includes 13F AIT, 74F AIT, Primary Leadership Course, Basic 
Non-Commissioned Officers Academy (13F) and Advanced Non-Commission Officers Academy (74F) (I 
was a distinguished graduate from most of these.).    My civilian education includes a High School 
Diploma, 2 years trade school for Auto Mechanics and an Associated Degree in Computer Science.

I worked as an auto mechanic for two years after graduating from high school in Greenville, Illinois and 
then worked for four years as an industrial electrician before joining the Army.

I started with computer programming by learning Basic and then Machine Language programming on a 
TRS-80 Model I starting in 1979.    Some of my accomplishments in that arena were a complete operating 
system of my own, a tactical forward observer training program, a menu system (later known as Gmenu 
or Vmenu), a OS Shell (later known as Auto or Valet) and a few games.

In 1981, I picked up Cobol programming through the Army.    From 1982 through 1986, I taught IBM DOS-
E (mainframe) internals and debugging, Cobol Programming, Basic Programming, Systems Analysis and 
Design, GCOS (honeywell) and picked up IBM (mainframe) and GCOS (honeywell) Assembler Language 
programming.    I also taught some of the above courses for University of Maryland and City Colleges of 
Chicago (overseas).

In 1986, I started learning about IBM PCs and MS-Dos.    I developed a few assembler language 
programs based on older TRS-80 programs such as Auto and Gmenu.      I also learned C, Pascal and 
FORTRAN around this time and released a few shareware games written in C and Pascal.

I was introduced to UNIX in 1987 and developed a whole series of programs for UNIX in C, including a 
version of Gmenu (menu shell), Gmail (mail interface for sendmail, mmdf and more), Rbbs (USENet 
interface), FSE (full screen editor), Ginput (forms input system) and a simple hypertext information 
system.    Much of this was later adopted by the Army and distributed with standard systems.    It is all still 
in use at West Point and full source code is available.      Some parts of it were also adopted by colleges 
and universities across the country.    Over 90% of the development of all the UNIX programs was 
performed at night at home in addition to my regular military duties.

Also in 1986, I was introduced to the world of networking and went on to help develop the extensive 
TCP/IP network in place at West Point.    My involvement included design, installation, testing, operation 
and maintenance of much of the network including both the physical network and the software that ran on
the PCs, on network devices and on the host systems.    I was involved in every aspect of the network 
including implementation of network management tools which is where WS_Watch has its roots.    The 



network at West Point when I left in 1993 had 12 FDDI routers, 40+ subnets and over 6000 nodes.    
There were over 40 UNIX host systems, 15 Lan Manager servers, 3 Novell servers, a couple IBM 
mainframes, a Unisys 1100 mainframe, a Teradata mainframe, a few DEC VMS systems and other 
miscellaneous systems on the network, all of which I had something to do with (from a network 
configuration point of view).    (Myself and two people working for me, did all the system support on 23 of 
the UNIX systems and provided all the system support on the Lan Manager servers for a couple of years 
while we did everything else!)    Also at the beginning of this time period I took over the support of the 
Domain Name Server for usma.edu and assisted in setting up the first army.mil name server.

Since 1993, I have taken on more freelance programming work outside the Army and have produced 
network related products such as WS_Ping, WS_FTP, WS_GMail, WS_News and WS_Watch.    This is 
outside of my normal job where I have been assisting in the design of a new network at Fort Gordon and 
in moving Fort Gordon into the future of automation.    Our current network initiatives include 
implementation of ATM in conjunction with the Army SBIS program (an addition to).    One of our 
accomplishments here is in the setup of the Signal Center Web Home Page at 
http://www.gordon.army.mil.

My hobbies are (you guessed it!) computer programming, chess, working on cars, building car models 
and spending time with my wonderful wife Denise, my three daughters and my grand-daughter Madison.

John A. Junod
267 Hillwood Street
Martinez GA 30907
(706)-860-5308

<junodj@css583.gordon.army.mil>
<junodj@csra.net>
<junodj@martinez.ipswitch.com>
<72321.366@compuserve.com>




